renephoenix.de

Internet Explorer und der Rahmen

Ich habe eine Reihe von Beiträgen auf einer Seite. Jeder Beitrag enthält eine Kopfzeile, einen Titel, einen Inhalt und einen Fuß. Dieser sollte zur Visualisierung eingerahmt werden (je 1 Pixel, keine doppelten Rahmen). Alles funktionierte auf Anhieb. Mißtrauich schaue ich doch noch einmal mit dem IE das Ganze an.

Die Rahmen sind alle an der richigen Stelle – nur der dargestellte Inhalt aller vier Elemente rutscht je Beitrag um 2 Pixel weiter nach links, die untersten haben ihren Rahmen bereits verlassen.

Allerdings tritt der Fehler nur auf, wenn

  • der Bereich Blockelemente enthält (hier der Absatz) und
  • der Bereich einen linken und/oder rechten, jedoch keinen unteren Rahmen enthällt.
  • der padding-bottom (unterer Innenabstand) größer 0 ist

Ich nehme also der Fußzeile den oberen Rahmen weg, und gebe nun dem Inhalt einen unteren Rahmen – und es funktioniert so, wie gewollt. Ob solche Fehler dann mit dem IE 7 auch beseitigt sind?

Allerdings gibt es unterschiede zwischen dem lokalen Betrachten und über einem Server, auch wenn beide Varianten etwas merkwürdig aussehen!

Bisherige Kommentare (4)

Kommentar von René

Der Fehler betraf eine andere Seite, ich erstelle eine kleine Demonstration.

zum Ruckelproblem: ich bin ehrlich gesagt noch nicht dazugekommen. Es gibt den Link »Altes Layout«. Zur Not das erst einmal benutzen. Deine Vorschläge werde ich erst einmal durchtesten ... ;-)

Kommentar verfassen

Freiwillige Angabe
Freiwillige Angabe
Der Text kann mit Textile formatiert werden, z.B. *fett* _kursiv_ "link":url. Wie das geht?
Wieviel ist 40 plus 2?

Bisherige Trackbacks (0)

Es wurde noch kein Trackback empfangen!